Gifs not loading properly

Aaron

<Donors Crew>
3,566
11d 15h 36m
Reactions
3,422 287 0 0
#1
So, starting a couple of weeks ago GIFs on this forum stopped loading propperly, at least some of the time. They seem to load fine if they are on the part of the page the monitor is displaying, but they don't seem to load above or below it. That means after viewing a couple of posts, I scroll down and then have to reload the page to get them to load. The look like this before reloading. Note, this only seems to be an issue on Chrome in Windows 10 (both at home and at work). Other browsers and Chrome on my mobile work fine. Anyone know what might be the issue?

wat.PNG
 

lurkingdirk

<Donors Crew>
14,135
22d 2h 33m
Reactions
5,338 1,162 0 0
#2
Same has been happening for me in multiple browsers.
 

Denamian

Night Janitor
<Prior Amod>
2,062
31d 5h 29m
Reactions
2,074 150 0 0
#3
This has been brought up several times in the amod thread over the last few months. I don't know if a specific cause has been identified.
 

Lanx

Aten Ha Ra Slayer
18,083
52d 13h 34m
Reactions
29,416 5,866 0 0
#4
This has been brought up several times in the amod thread over the last few months. I don't know if a specific cause has been identified.
it has, this shit didn't happen until we upgraded to xen2 then gifs goto shit

at first i thought it might be too many "elements" per page which is why i changed my FSR format from 3 per post to just 1 and push all the elements to a new page load.
 

Denamian

Night Janitor
<Prior Amod>
2,062
31d 5h 29m
Reactions
2,074 150 0 0
#5
it has, this shit didn't happen until we upgraded to xen2 then gifs goto shit
Sounds entirely possible to me that it could be part of the cause. It also could be the media embed plugin or even some shit on Imgur's end, as I've only seen it happen to Imgur gifs. Shit's beyond me.
 

Lanx

Aten Ha Ra Slayer
18,083
52d 13h 34m
Reactions
29,416 5,866 0 0
#6
Sounds entirely possible to me that it could be part of the cause. It also could be the media embed plugin or even some shit on Imgur's end, as I've only seen it happen to Imgur gifs. Shit's beyond me.
yup, only imgur; it's not an issue if you want to just click to see what shit is posted, but it pops a new tab n shit.
 

Aaron

<Donors Crew>
3,566
11d 15h 36m
Reactions
3,422 287 0 0
#7
True, come to think of it. It's only imgur. Gify's work fine. Hope a solution can be found.
 

Gamma Rays

[REDACTED]
<Donors Crew>
2,833
14d 5h 38m
Reactions
4,866 2,120 0 0
#8
Sometimes the imgur GIFs don't play, I get a frozen image. But the 'fix' is to click on the GIF which loads it in a new tab and it plays fine.

Not too big an issue as the fix is easy, but worthy to point out that it is imgur.
 

Soygen

The Dirty Dozen For the Price of One
<Donor All-Stars>
24,232
29d 21h 54m
Reactions
22,345 1,638 0 0
#9
Yup, it's very annoying.
 

Hoss

Make America's Team Great Again!
<Donors Crew>
12,109
12d 5h 6m
Reactions
4,322 798 0 0
#10
Only happening to me for lanx posts. After reloading the page a few times I realized his pictures aren't worth the effort.

i notice your screenshots happen to be lanx posts too.
 

suineg

<Donors Crew>
27,563
31d 12h 0m
Reactions
22,689 2,262 0 0
#11
It is specific to imgur and the way they embed and has nothing to do with XF2.

Eventually we are going to code our own workaround.
 

AngryGerbil

PC NPC
<Donors Crew>
14,560
Reactions
17,982 1,064 0 0
#13
it has, this shit didn't happen until we upgraded to xen2 then gifs goto shit

at first i thought it might be too many "elements" per page which is why i changed my FSR format from 3 per post to just 1 and push all the elements to a new page load.
Your avatar is giving me nightmares.
 

Hoss

Make America's Team Great Again!
<Donors Crew>
12,109
12d 5h 6m
Reactions
4,322 798 0 0
#17
I'm not worried. In my dream I told her my name is moonarchia.